LSP 1.0 Enigma Installation Guide
   This Installation Guide assumes a basic knowledge of FTP and web site configuration.

Contents:
- Getting Started
- Installation Notes
  - Full Install
  - Upgrade Install

 Getting Started

Is your host/server running up-to-date versions of PHP and MySQL?
Download http://www.yabbse.org/manual/phpinfo.zip, unzip the package and upload the file phpinfo.php to your host. Open your browser and in your address bar type: e.g.. 'http://www.mysite.com/phpinfo.php' Your hosts PHP version is right at the top of the page, and mySQL version (if installed) is half way down.
Is your server's PHP running in Safe-mode?
Check the phpinfo.php page again and scroll down to 'Configuration >> PHP Core'. Near the bottom of the list you will find the value for safe_mode; all your interested in is the local value, not the master. (If its not listed, talk to your host. Most free hosts have Safe-Mode enabled.)
Recommended Versions of PHP & MySQL to run Enigma

PHP 4.1.x  -  Unix/Win32 Platforms
mySQL 3.23.x  -  Unix/Win32 Platforms

Note: In order to do an upgrade install, your must be currently running YaBB SE 1.5.4 or a portal that is based on the YaBB SE 1.5.4 code.

 Installation Notes
Standard Install
Upgrade Install


Standard Install


Fresh Install Instructions:

1) Unzip the contents of the LSP v1.0 "Enigma" package.

2) Connect to your server via FTP or any other means.

3) Upload the Enigma folder (rename it if you wish) and it's entire contents.

4) Open your browser and in the address bar type: e.g. 'http://www.mysite.com/Enigma/install.php'

5) Follow the on-screen steps, double check that you've provided correct information.

6) When you've completed the installation and your board is running, delete install.php, upgrade.php and the folder "upgrade" with all it's contents



Upgrade Install


Upgrade Install Instructions:

1) Backup Everything. Backup all of you files, and backup your database. Lunabyte Systems is not responsible for any data that you lost because you didn't back it up properly.

2) Unzip the contents of the LSP v1.0 "Enigma" package.

2) Connect to your server via FTP or any other means.

3) Open the directory that currently holds you forum or portal files (here-after referred to as the root directory).

4) Upload the following folders and their contents into the root directory:
     (Note: You'll want to overwrite any and all of the files.)

   /Enigma/attachments/*.*
   /Enigma/dls/*.*
   /Enigma/Packages/*.*
   /Enigma/Skins/*.*
   /Enigma/Sources/*.*
   /Enigma/upgrade/*.*
   /Enigma/YaBBHelp/*.*
   /Enigma/YaBBImages/*.*
               
5) Upload the following files into the root directory:
     (Note: You'll want to overwrite any and all of the files.)
     (Note: Do NOT overwrite your Settings.php file.)

   /Enigma/documentation.html
   /Enigma/english.lng (and/or other language file if available)
   /Enigma/fader.js
   /Enigma/help.php
   /Enigma/helpadmin.help
   /Enigma/index.php
   /Enigma/QueryString.php
   /Enigma/readme.html
   /Enigma/ubbc.js
   /Enigma/upgrade.php
   /Enigma/yabbinfo.xml
               
6) Open your browser and in the address bar type: e.g. 'http://www.mysite.com/Enigma/upgrade.php'
     (Note: Once the script is done loading your all done.)

7) At the first prompt, choose the version of software from which you are upgrading.

8) Follow the remaining instructions on the screen, clicking "Proceed" when told to do so.
     (Note: Please copy any error messages that you receive so that you can refer back to them when asking for help.)

9) When the upgrade is finished, delete upgrade.php, the upgrade folder, and its entire contents



Powered by MySQL Powered by PHP Install Guide Valid XHTML 1.0! Valid CSS!